Customer.io is experiencing issues with Email Sending
Incident Report for Customer.io Status
Resolved
The issue is now resolved. All Failed Emails will retry automatically.
Posted May 27, 2024 - 14:25 UTC
Monitoring
A fix has been released for the issue and we are currently monitoring for performance and to ensure messages are being sent correctly.
Posted May 27, 2024 - 14:17 UTC
Update
Our Investigation has shown that this only impacts our Customers hosted on the US Data Center. This issue also does not impact customers with Custom SMTP solutions.
Posted May 27, 2024 - 14:10 UTC
Identified
We have received multiple reports of Messages Sending Failures. Our team is aware of the issue and we are working on a fix.
Posted May 27, 2024 - 14:00 UTC
This incident affected: Message Sending.