New account and workspace creation is affected.

Incident Report for CustomerIO

Resolved

Account and workspace creation are working as expected again.
The incident has been resolved.
Posted Feb 07, 2025 - 00:13 UTC

Monitoring

A fix has been deployed and we are monitoring the health of the systems.
Posted Feb 07, 2025 - 00:10 UTC

Identified

The team has identified the issue and is in the process of deploying a fix.
Posted Feb 07, 2025 - 00:07 UTC

Investigating

Some customers may experience issues creating new accounts and / or workspaces.
We are aware of the issue and are actively working on a fix.
Posted Feb 07, 2025 - 00:06 UTC