Some customers in EU data center are experiencing delays in data processing and deliveries. No other functionalities are impacted. We are investigating.
Incident Report for Customer.io Status
Resolved
This incident has been resolved.
Posted Feb 11, 2024 - 19:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2024 - 19:35 UTC
Investigating
We are currently investigating this issue.
Posted Feb 11, 2024 - 19:10 UTC
This incident affected: Data Processing and Message Sending.