Twilio Templates Outage

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:07 UTC

Monitoring

We are no longer seeing intermittent errors from the upstream provider for Twilio templates. We are continuing to monitor message delivery.
Posted Oct 20, 2025 - 19:42 UTC

Identified

We are experiencing intermittent errors with our upstream provider for Twilio templates. Customers may see errors in our UI while trying to manage Twilio templates, and delivery of Twilio messages may be delayed. No other functionality of our platform is known to be affected.
Posted Oct 20, 2025 - 18:45 UTC
This incident affected: Message Sending and Management Interface.