Delays in data processing in the EU region
Incident Report for Customer.io Status
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 18:09 UTC
Update
We are continuing to investigate the issue.
Posted Nov 22, 2023 - 17:34 UTC
Update
We are continuing to investigate the issue.
Posted Nov 22, 2023 - 16:29 UTC
Investigating
We are currently investigating an issue with delays in data processing for some customers in the EU region. We do not anticipate any loss of data and all other functionality is working as expected.

There is no impact on the US region.
Posted Nov 22, 2023 - 15:35 UTC
This incident affected: Data Processing.