Some customers in our EU region are experiencing delays

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 16:49 UTC

Monitoring

We have a resolution in place now, and backlogs are currently being processed. We'll be back with an update once the issue is all clear.
Posted Sep 26, 2025 - 16:32 UTC

Identified

Our engineers identified an issue that may cause some customers with accounts in our EU may to experience delays with data processing and message sending, as well as UI errors.
Posted Sep 26, 2025 - 16:17 UTC
This incident affected: Data Processing.