Reduced Deliverability to Microsoft-Hosted Email Addresses

Incident Report for CustomerIO

Resolved

Microsoft has resolved the underlying issue, we are seeing deliveries to their services resume as normal. Earlier bounces will be retried accordingly. We appreciate your understanding and please do reach out to support if you need any further assistance.
Posted Sep 04, 2026 - 13:35 UTC

Monitoring

Starting around 08:00 UTC, Microsoft began experiencing an incident causing an increased volume of deferred/bounced emails. We are actively monitoring the situation. No other email providers are currently affected.
Posted Sep 04, 2026 - 12:30 UTC

Investigating

We are currently investigating reports of reduced deliverability affecting messages sent to Microsoft-hosted email addresses. Our team is actively looking into this and we will provide an update as soon as we have more information. Thank you for your patience!
Posted Sep 04, 2026 - 12:16 UTC
This incident affected: Message Sending.