Intermittent loading issues in the User Interface
Incident Report for Customer.io Status
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 19:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2023 - 19:27 UTC
Investigating
Some customers may be experiencing issues accessing the Journeys User Interface in the US datacenter. The team is investigating. All other functionality is functioning properly. The EU datacenter is not affected.
Posted Nov 17, 2023 - 19:24 UTC
This incident affected: Management Interface.