Delays in sending and UI experience

Incident Report for Customer.io Status

Resolved

The issue has been resolved.
Posted May 07, 2025 - 00:35 UTC

Monitoring

The issue has been fixed and the team is monitoring to ensure all data is processing properly. The access to the user interface and APIs is restored.
Posted May 07, 2025 - 00:28 UTC

Identified

Some customers in the US datacenter are experiencing delays in message sending and may experience interruptions when using the user interface or APIs. The team has identified the issue and are working towards a solution.
Posted May 07, 2025 - 00:19 UTC
This incident affected: Message Sending and Management Interface.