Legacy in-app editing, delays receiving in-app messages and Journeys domain verification with Cloudflare

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 14:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 14:43 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 14:16 UTC

Update

Customers may experience issues when verifying new domains associated to Cloudflare. The team is continuing to work towards a resoltuion.
Posted Nov 18, 2025 - 13:46 UTC

Update

The team is continuing to work towards a resolution.
Posted Nov 18, 2025 - 13:18 UTC

Update

During the investigation, it was discovered that some customers are experiencing delays in receiving in-app messages.
Posted Nov 18, 2025 - 12:46 UTC

Identified

Customers using the legacy in-app message editor may encounter issues when trying to edit messages. Sending and viewing of existing messages are not affected.
The team has identified the root cause and is actively working to restore the functionality.
Posted Nov 18, 2025 - 12:28 UTC
This incident affected: Management Interface.