Design Studio isn't loading

Incident Report for Customer.io Status

Resolved

The incident has been resolved and Design Studio loads correctly for all accounts.
Posted Jul 19, 2025 - 01:18 UTC

Update

Functionality has been restored for most customers, however there are still edge cases we are looking into.
Posted Jul 19, 2025 - 00:21 UTC

Monitoring

We have deployed a fix and are actively monitoring the system
Posted Jul 19, 2025 - 00:06 UTC

Identified

The team has identified the root cause and is working on a fix.
Posted Jul 18, 2025 - 23:24 UTC

Investigating

We have identified an issue with the beta Design Studio not loading and are working on a fix. No message sending or data processing is affected.
Posted Jul 18, 2025 - 23:23 UTC