Customer.io UI is currently inaccessible

Incident Report for CustomerIO

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 13:42 UTC

Monitoring

We've got a fix in place, and the UI is available once again. Thank you for your patience!
Posted Jun 04, 2026 - 13:39 UTC

Investigating

Our team is aware of this issue and are digging into it right now. We apologize for the inconvenience and will be back with an update as soon as possible.
Posted Jun 04, 2026 - 13:34 UTC
This incident affected: Management Interface.