New accounts experiencing issues navigating UI

Incident Report for Customer.io Status

Resolved

The issue has been resolved.
Posted Apr 03, 2025 - 09:50 UTC

Update

The issue affects new accounts' ability to navigate around the workspace. Team continues to investigate.
Posted Apr 03, 2025 - 08:23 UTC

Investigating

We are aware of the issues with creation of new accounts for some customers. Team is investigating.
Posted Apr 03, 2025 - 07:41 UTC
This incident affected: Management Interface.