Some customers on the US Data Center may experience Message Delays.

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 15:05 UTC

Monitoring

The fix has been deployed, and Message sending is fully restored. The team is monitoring the system.
Posted Jul 18, 2025 - 14:42 UTC

Update

The team is still working on a fix.
Posted Jul 18, 2025 - 13:26 UTC

Update

Our team is continuing to work on a fix.
Posted Jul 18, 2025 - 12:18 UTC

Update

Our team has confirmed that the scope of impact is narrow. We continue to work on a fix.
Posted Jul 18, 2025 - 11:03 UTC

Identified

Our team has identified an issue that is causing some messaging to encounter delays. Our team is currently working on a fix
Posted Jul 18, 2025 - 10:29 UTC
This incident affected: Message Sending.