Some customers in the EU region are seeing delays in message sending. User Interface may be impacted , as well. There is no data loss and all other functionalities are working as expected
Incident Report for Customer.io Status
Resolved
This incident has been resolved.
Posted May 24, 2024 - 18:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 24, 2024 - 17:51 UTC
Investigating
We are currently investigating this issue.
Posted May 24, 2024 - 17:49 UTC
This incident affected: Message Sending.