Data processing is seeing some delays in the US region
Incident Report for Customer.io Status
Resolved
The issue has now been resolved, Data Processing services have been fully restored.
Posted Jan 04, 2024 - 05:04 UTC
Monitoring
A fix has been applied by our engineering team. We are expecting the issue to be resolved in the next 60 minutes.
Posted Jan 04, 2024 - 04:22 UTC
Investigating
Some customers in our US region are seeing delays with processing of deliveries. We are currently investigating this issue.
Posted Jan 04, 2024 - 04:18 UTC