Customers unable to access some parts of the Customer.io UI

Incident Report for Customer.io Status

Resolved

This incident has been resolved. Thank you for your patience!
Posted Jul 03, 2025 - 20:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2025 - 20:12 UTC

Investigating

We're investigating an issue that is preventing customers from accessing some parts of the Integrations page, In-App Visual Editor, and Design Studio.
Posted Jul 03, 2025 - 19:55 UTC
This incident affected: Management Interface.