Customer.io UI is inaccessible
Incident Report for Customer.io Status
Resolved
Our team has confirmed the fix we deployed has resolved the issue.
Posted Jun 24, 2024 - 16:06 UTC
Monitoring
The issue has been identified and we have deployed a fix to unblock affected customers, and we're currently monitoring performance.
Posted Jun 24, 2024 - 15:59 UTC
Investigating
An issue has been identified; the engineers are working on restoring availability. Data processing is not impacted.
Posted Jun 24, 2024 - 15:47 UTC
This incident affected: Management Interface.