Google Ads operations delayed.

Incident Report for Customer.io Status

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 03:43 UTC

Investigating

We're currently experiencing intermittent issues sending data to Google Ads.
Additionally, some customers may notice longer load times on the integrations page.
Posted Jul 02, 2025 - 22:17 UTC