Delivery time windows incorrectly evaluated as UTC
Incident Report for Customer.io Status
Resolved
We've finished processing all affected campaigns. Any unsent messages will be sent in the next available time window.

We are taking actions to improve our architecture to avoid further occurrences of this issue. Our apologies again for any hardship caused by this problem.
Posted Apr 17, 2018 - 22:54 UTC
Monitoring
Yesterday, April 16, 2018, at 9:07 pm UTC we deployed a bug that caused delivery time windows to be evaluated in UTC instead of the time zone you defined. In some cases, if you have time windows defined, your campaign may have emailed a customer outside of the permitted time window or may not have emailed them yet.

A fix has been deployed at 2:38 pm UTC today, and we’re actively working to correct the delivery time for any pending deliveries. We'll follow up with an update as soon as this is done.

We apologize for any deliveries sent at the wrong time due to this incident.
Posted Apr 17, 2018 - 16:02 UTC