Delayed Newsletters and Broadcasts in Europe
Incident Report for Customer.io Status
Postmortem

Incident Summary

On Friday November 25th, 2022, between 14:57 and 18:53 UTC customers may have experienced a delay in outbound message delivery. This incident only affected the EU datacenter. The US datacenter was functioning properly.

This issue did not affect inbound data ingestion to our system. Once the issue was resolved outbound message delivery resumed and no messages were lost as they were queued during the incident.

Customer.io would like to apologize for the impact of this outage. We are committed to learn from this event and use it to drive improvement across our services.

Root Cause

Starting at 11:00 UTC on Nov 25th an abnormally large number of customers initiated broadcasts. This rise in volume is normally handled well by our autoscaling system, however, due to two unusually large sends the autoscaling failed to keep up with demand and we had to fall back to manually scaling the system.

Resolution and Recovery

Once the issue was identified, the team disabled some large sends and manually scaled the system. The manual corrections allowed the vast majority of sends to complete promptly, and we then worked to manually mitigate the remainder.

At 18:53 UTC on November 25th, 2022, the backlog was cleared, all messages were delivered, and the incident marked as resolved.

Corrective and Preventative Measures

We are working on improving the message sending autoscaling to better handle sudden increases in load.

Posted Dec 07, 2022 - 12:28 UTC

Resolved
This incident is now resolved. All customers should be seeing normal rates sending newsletters and broadcasts.
Posted Nov 25, 2022 - 18:54 UTC
Monitoring
Efforts to restore the system have been successful and all customers should be seeing improvements in the rate of newsletter and broadcasts sending. There is a backlog of newsletters and broadcasts that we expect to be cleared within the hour. The CIO team is continuing to monitor the system.
Posted Nov 25, 2022 - 18:33 UTC
Update
The CIO team is continuing to work on a resolution but are seeing significant improvements in the sending of newsletters and broadcasts.
Posted Nov 25, 2022 - 17:43 UTC
Update
The CIO team is continuing to work on a resolution. Most customers will see an improvement on sending newsletters and broadcasts.
Posted Nov 25, 2022 - 16:48 UTC
Identified
The issue has been identified and most customers will start to see an improvement on sending newsletters and broadcasts. The CIO team is continuing to work on resolution of the issue.
Posted Nov 25, 2022 - 15:53 UTC
Investigating
Some customers in the Europe datacenter are experiencing a delayed rate of sending newsletters and broadcasts. Other email deliveries are working including event triggered and transactional emails.
The CIO team is investigating the issue and will update the status as we progress.
Posted Nov 25, 2022 - 15:26 UTC
This incident affected: Message Sending.