Delays in email delivery
Incident Report for Customer.io
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 04, 2019 - 16:35 UTC
Monitoring
The problem has been identified and addressed, we are now processing the queued email messages.
Posted 3 months ago. Jun 04, 2019 - 15:23 UTC
Identified
We are experiencing delays in email delivery. Our team is working to resolve the issue.
Posted 3 months ago. Jun 04, 2019 - 15:03 UTC
This incident affected: Email Sending.