West coast API collection servers slow
Incident Report for Customer.io Status
Resolved
All clear! Our west coast API servers are back to normal.
Posted Feb 19, 2018 - 05:00 UTC
Update
We've adjusted our west API servers to better process inbound requests while clearing the backlog. We'll continue monitoring and resolve this incident at 5:00 UTC as long as performance stays nominal.
Posted Feb 19, 2018 - 03:56 UTC
Monitoring
We're monitoring our API servers as they continue to process the backlog of API calls working towards recovery. We'll post another update at 4:00 UTC
Posted Feb 19, 2018 - 03:35 UTC
Update
We're working on clearing the backlog of API calls to our west coast collection servers. We'll post another update at 3:00 UTC
Posted Feb 19, 2018 - 02:35 UTC
Update
We're continuing to work with the source of the flood of traffic to our API to reduce the load and restore availability. We'll post another update at 2:30 UTC
Posted Feb 19, 2018 - 02:02 UTC
Identified
We've reached out to the source of the request flood and confirmed they've disabled the requests. Further updates at 1:45 UTC.
Posted Feb 19, 2018 - 01:32 UTC
Update
We've identified the cause of the request flood and are looking for reasonable ways to resolve the issue. Further updates at 1:30 UTC.
Posted Feb 19, 2018 - 00:47 UTC
Investigating
Our west coast API collection servers are having some issues cause by what looks like request flood. We're investigating what is occurring. We'll post a further update at 00:45 UTC.
Posted Feb 19, 2018 - 00:16 UTC